Payroll Information Extract (PIE)
Payroll Data Extract
HR Deducting Departments

The Payroll Information Extract (PIE) was designed to provide organizations the ability to
access detailed payroll information. The user submits the parameters for the report; the
information is extracted and the report sent in an excel spreadsheet. The requestor receives
an email notice when the report has been generated. The report may be accessed by
selecting the correct notification in the requestor’s worklist.
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Payroll Data Extract

HR Deducting Departments

The extract provides specific information as outlined below:

Detail Extract

Person Summary Extract

Element Summary Extract

Full Mame
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Employee Number

Employee Mumber

Assignment Number

Assignment Mumber
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Employment Category

Employment Category

Payroll Name

Payroll Name

Date Paid

Date Earned

Period Mame

Fay Period Start Date

Pay Period End Date

Assignment Organization

Assignment Organization
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Assignment Organization Unit

Assignment Organization Unit
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Class Code

Class Code

Element Mumber

Elerment Mame

Element Mame

Reporting Mame

Reporting Mame

Element Classification

Element Classification

Eamings Type

Pay “alue

Total Pay “alue

Tatal Pay “alue

Element Count

Tenure Status

Tenure Status

Tenure Track Date

Tenure Track Date

Tenure Award Date

Tenure Award Date

Tenure Review Date

Tenure Review Date

=pecial Tenure Circumstances

special Tenure Circumstances

The top portion, DATA TYPE / DATE RANGE, of the form is used to establish the type of data
and date ranges desired by the requestor.
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In the DATA field, click the radio button next to Payroll. The requestor may elect to receive
detail or summary information on the report. Select the radio button next to the desired
criteria. Selecting the SUMMARY option activates the PERSON and ELEMENT buttons.

Payroll > Detall Payroll > Summary > Person/Element

S Payrall

i Payrall

D Detail  ®Summary ® Detail

rson W Elemeant
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The requestor must determine the time period to select in the TYPE field. The options are
ALL (four quarters per year), Q1 (1 quarter), Q2 (2" quarter), Q3 (3" quarter), or Q4 (4™
quarter.)

alendar

Date Paid
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The requestor must consider the TYPE and DATE fields collectively. The requestor may
retrieve data from any 12-month period. Dependent on the time period selected, the DATE
field will enable the requestor to input the extract parameters.

Calendarl > Date Paid > All
Date
alendar Year Month Day
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Calendar > Date Paid > Q1, Q2, Q3, Q4
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The MAIN CRITERIA portion of the document is restricted according to the requestor’'s system
security including the organization(s) and responsibilities. These restrictions are the same as
those for THE APPOINTMENT, CHANGE, AND TERMINATION (ACT) document.

The requestor may define the extract criteria utilizing a single field or a combination of fields.

Main Criteria

To select an employee by NAME, type the individual’s name (Last Name, First Name) or
type a partial value including the percent (%) sign and press the Tab key on the keyboard.
A listing of available names will appear. Select the appropriate person and double click or
select OK.

'FuII MHame

SRERR o Mitchell, K%

et Set

lerment

FuII MHarme Employee Mumber
: 1

Mitchell, Keenya L 1022061
Mitchell, Kendrick T 1015514
Mitchell, kevin B. 1038006
Mitchell, Kimberlee Stanton 10063049
Mitchell, Kimberly b 1015971
Mitchell, kimberly b 1034484
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To use the JOB number as a criteria, enter the job number or use the percent (%) sign and
any applicable numbers or letters and press tab. All available listings will appear. Select the
appropriate job and double click or select OK.

r._I ob

Al %Ass0c%

0028 Assoc Dean

0124 Aszoc Profiasst Dean
0129.Rezearch Azsoc Prof
0130.Ass0c ProfiDirector
0131 .Assoc Prof
0133.Ass0c ProffChairman

Extract criteria may also be filtered by ORGANIZATION. Leaving the organization field blank
will extract all organizations to which the requestor has access. To select an organization,
the requestor may use partial values (i.e. letters or numbers) and the percent (%) symbol.
Double click the correct organization or highlight the selection and select OK.

Crganization

ion Science Research Center
339202000 %ision Science Graduate Program
392000000 Cell Binlogy
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Data may also be filtered according to the ELEMENT SET. The default, UAB PIE HR
Deducting Elements, contains all deducting elements. To further define the element set,
select the LOV and a listing of element categories will appear. Select the element and
double click or select OK.

Elerment Set [UAB PIE HR. Deducting Elements

Element Set

Fjisf AR PIE HR Deducting %

_Element_Set_Marme

Ly R
AR PIE HR Deducting Athletics
AR PIE HR Deducting Benewolent

Using the ELEMENT criteria enables the requestor to view the specific elements that are
associated with the element sets. Select the LOV and all elements pertaining to the defined
element set with appear. Select the element and double click or select OK.

Element

rElernent

ark L FA 3 4-1H g E LV [arking ae
Alys Robinsan AR DD ARSC Alys Robinsan Stephens Center

Athletic Ticket LIAB DD B TICKETS Athletic Ticket Baskethall

BEREY Des Single RFD LUAB RFD BF 5 DES Benev Designated Single Refund
BEMEY Lindes Single ... AR RFD BF 5 LMD Fefund Benevalent Fund Undesignated Si...

Ben Fund AR DD BF DES Benevolent Fund Designated
Aan Fund L&A M0 BE LR Aenewnlsn i
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To request only individuals with a specific payroll, use the PAYROLL TYPE filter. Place the
cursor in the field and an LOV will be activated. Click the LOV and all applicable payroll
types will appear. Select the correct payroll type and double click or select OK.

Payrall Type

'F' ayroll Mame

412 Monthly

12112 monthiy Faculty
Biwieekly

Manthly

Trainea

D |

Use the ASSIGNMENT CATEGORY (ASMT CATEGORY) filter to select only individuals in a
specific assignment or employment group. Place the cursor in the field to activate the LOV.
Click the LOV and all applicable data will appear. Highlight the correct assignment
category and double click or select OK.

01 RegularFT
02 Temporary FT

M 03 RegularPT
04 Irregular
06 Student
07 Resident
11 Federal Work Study
12 Three 12-Hour Shifts

After selecting all extraction filters,
click Submit.
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The NOTE BOX will inform the requestor that the report will be available as a workflow

notification. A request id number will also be included should the requestor experience any
problems accessing the extract.

attachment after
report the

The requestor will receive an email with instructions to access the report. The email will also
contain the extract parameters of the report.

B Payroll Information Extract: 3200947 See Workflow Motification. - Message (Plain Text)

. File Edit  Wiew Insert  Format  Tools  Actions  Help

E-L,}tgeply L%Replytonl_l gy Forward | & Ba | L4 | ¥ l% A5 K| e w - N IQ)!

Extra line breaks in this message were removed.

Froarn: o TUCC . PRODUCTION. CONTROL@uab.edu Sent:  Thu8/10/2006 2:10 PM
To: Kimberly 1 Mikchell
o

Subject:  Payroll Information Extract: 3200947 See WaorkFow Motification.

File has been delivered wvia Workflow Notification. Submission Parameters: 2
Person SIUMMARY - Payroll; Org Type: All; Element: *Parking; Element Jet: TAB
PIE HE Deducting Parking; Frow Date Paid: 01-JAN-06; To Date Paid: 31-JAN-O6

Arguments/Parameters passed to the program -- F, , . , , ., ., , 7829, *Parking,
ULE PIE HR Deducting Parking, , , , , O1-JAN-06, 31-JAN-06, ., . + + s s r r + »+
20 o o , kwitehellfuab.edu, EDMM1, UAE HE Deducting, , , Person, A&l11, .,

EEEE

Please do not reply to this message. If you have any questions, please get in

touch with either TUCC Production Control or TUCC Technical staff.
TEEHE

To access the notification containing the report, select the Personal Worklist menu item
under the Workflow responsibility on the PERSONAL HOME PAGE.

Workflow:Personal Worklist

ACT
+ Processes and Reports

Payroll Information Extract (PIE)
- Workflow

=
WAM--Approval Paths .
Personal Worklist
UAB Document Locator *

Fele® [0 [+
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Click on the correct notification in the WORKLIST.

Wiew IOpen Motifications j |Go | (_Personalize |

Select Notifications: (_Open | ( Reassign
Select All | Select Mone

Select From |Type |Suhjectf |Sent
O WELAE Message Report Sent by UAB Matification Mailer 26-Jul-2006
r WFUAB Message ~ Report Sent by UAB Notification Mailer ~ [10-Aug2006
O WEUAE Message Report Sent by UAB Matification Mailer 26-Jul- 2006

@ TIP “acation Rules - Redirect ar auto-respond to notifications.

The notification will contain the extract parameters submitted by the requestor. Click the
view report link on the NOTIFICATION. The requestor should pay particular attention to the
note regarding access to the report. The statement reads as follows:
**“NOTE 1: For Security reasons this report will be viewable only once. i.e. once you
have viewed the report, you will no longer be able to click on the URL. To retain the
report click on File>Save and save to a local directory. Otherwise, to view it again, you
will have to regenerate the request.”

ORAC I_E ' Help  Cloze Windoww

(1) Information

This notification does nat require a response.

Report Sent by UAB Notification Mailer

——

| OK ) | Reassign | | Printable Page )

To  Mitchell, Kimberly M
Sent  10-Aug-2006 12:00:02

IDv 4224457
Request # 3200751: PIE Payroll Information Extract Submission Parameters: Elerment SUMMARY - Payroll; Org Type: All, Element: Ben
Fund; Element Set: UAB PIE HR Deducting Elements; From Date Paid: 01-JAN-06; To Date Paid: 31-MAR-06

The repart file can be accessed by clicking on the link below.
Wiew Report

NOTE 1: For Security reasons this report will be viewable only once. i.e. once you have viewed the report, you will no longer be able to
click on the URL. To retain the report click on File»Save and save to a local directory. Otherwise, to view it again, you will have to
regenerate the request.

Return to YWorklist (OK ) ( Reassign ) ( Printable Page |
¥ Display next natification after my respanse

Help | Close Window
Copryright 2000-2004 Oracle Corporation. &1 rights reserved. Privacy Staternert

***It is possible to retrieve requests by selecting View > Requests on the task bar.

Created 08/01/2006 9



Payroll Information Extract (PIE)
Payroll Data Extract
HR Deducting Departments

The FILE DOWNLOAD BOX will appear. Select Save.

File Download

Selecting save will launch the SAVE As WINDOW. The file will be authentically named using
the identification number (i.e. payroll_information_extract_id number.) The file will save as a
Microsoft Excel Worksheet. The requestor should select the appropriate file location.

EE | < e

PIE 2110799 [095E PO5);

FIE 2114835 [285EPO5)

FIE [Payroll Detail |

FIE [Pavroll Summarny Elerment]
_-'_E.:I FIE [Pavrall Summary Person]

payrall_infarmation_extract_1807703 |—
Microzoft Excel wWorkshest |—
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Once the location has been selected, click Save. NOTE: If desired, the requestor may
change the file name.

Comsbmsas B 9

T-—E.:I PIE 2110793 [O9SEPDS)

S| PIE 2114835 (285EPOS)

5] PIE [Paproll Detail |

F-'-,5‘.;1 PIE [Payroll Summary Element]
F-'-.E‘.':I PIE [Payroll Summary Perzson)

Dresklol [u}

%

by Documents

by Computer

S
-
BOF703 [240CT0O5)

Microzoft Excel wWorksheet |_

The DOWNLOAD STATUS BOX will appear indicating that the download has completed. Select
Open.

Download complete
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The spreadsheet will launch. NOTE: The extraction parameters are indicated on the first line
of the spreadsheet.

A | B [ & | D [ E
| 1 |Submission Parameters: Person SUMMARY - Payrall, Org Type: All; Element: "Parking; Element Set: UAB PIE HR Deducting Park
| 2 [FULL NAME EMPLOYEE_MUMBER |ASSIGMMEMNT _MUMBER PRIMARY _FLAG EMPLOYMENT CATEGORY |[PAYROD
| 3 |Andersaon, John 1002356 1002356 % 1 Biweekl
| 4 |Burton, Jogeph 1025637 1025637 Y 1| Manthly
| 5 |Cooper, Hannah 1345876 1345876 % 1| Manthly
6 |Martin, DeeAnn 1785691 1785691 Y 112012 W

The requestor may then manipulate the data as desired.
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