Software

Software Requirements to fully utilize this website:

Flash player plug-in version 10.0 or higher
Shockwave player plug-in version 11.0 or higher
HTML5 (H.264 video codec playability)
Adobe Acrobat Reader 9.0 or higher
Internet Explorer 7.0 or higher, Firefox 3.0 or higher, or Safari 4.0 or higher
Java Script Enabled
High-speed internet connection

For Mac users you may need OS-X 10.6 though we have tried to make all materials compatible with OS-X 10.5.

The most recent version of each is always recommended.

Troubleshooting tips:

  • Do not have multiple browser windows or tabs active simultaneously running Flash content or attempting to stream content.
  • If Flash content does not load, refresh the page.
  • Sometimes it may be necessary to delete the Flash history stored by your browser. Some browsers, such as Safari for Mac 10.5, store Flash history independently of browsing history. The method for deleting Flash history varies by browser. One method that usually works for all browsers on any OS is to right-click on the Flash content and select "Global Settings" and then select the "Website Storage Settings" panel. You may then delete either all history or select a particular website.